Saturday, May 18, 2013

brew Warning: Your Xcode is outdated even though I had last version

Yup. After installing XCode and after installing the Command Line Tools (Following Downloads/Components/Command Line Tools/Install) I still got issues with brew:
$ brew install aacgain
Warning: Your Xcode (4.2) is outdated
Please install Xcode 4.6.2.
...
The issue was related to a miss configuration:
$ xcode-select -print-path
/Volumes/Xcode/Xcode.app/Contents/Developer
And corrected when pointing to the right path:
$ sudo xcode-select --switch /Applications/Xcode.app 

4 comments:

Paloma said...

Thank you ! That helped me a lot !

Nestor Urquiza said...

@Paloma, glad I could help. Thanks, - Nestor

muthu kumar said...

$ brew doctor
Warning: Your Xcode (4.6.2) is outdated
Please update to Xcode 5.0.1.
Xcode can be updated from the App Store.
what can i do?
help me pls...

Nestor Urquiza said...

@muthu, I believe all you need to do is to install 5.0,1 from App Store just like it says. Did you do that and still you get the same message?

Followers